Cisco Internetwork Operating System (IOS) is a family of network operating systems used on many Cisco Systems routers and current Cisco network switches

Basic commands

  • show version or sh ver (includes uptime information)

Interfaces:

  • show interfaces
  • show interface trunk
  • show interfaces switchport. To display the administrative and operational status of a switching (nonrouting) port
  • show configuration or sh conf
  • show running-config or sh run An enable mode command that displays the current configuration
  • configure terminal or conf t Logs you into configuration mode


  • show ip
  • show ip interface
    • show ip interface brief or sh ip int br
  • enable Logs into enable mode. Also known as user exec mode or privileged mode. See also: show privilege
    • enable 5 Change to level 5
    • no enable password
  • show ip traffic
  • show logging
  • no shutdown. Enables an interface (brings it up).


  • ip route-cache
  • no ip route-cache
  • include, similar to grep linux command
  • show vlan [brief | id <vlan-id> | name <name> [ifindex] | <ifindex>]
    • show vlan
    • show vlan brief or sh vlan br
    • show vlan summary or sh vlan s
  • show ip route or show ip ro
  • username Create and delete users
  • show users
  • write
  • show crypto ca certificates

Access List

Configuring IP Access Lists: https://www.cisco.com/c/en/us/support/docs/security/ios-firewall/23602-confaccesslists.html#acltypes

Types of ACLs: Standard ACLs, Extended ACLs, Lock and Key (Dynamic ACLs), IP Named ACLs, Reflexive ACLs, Time-Based ACLs Using Time Ranges, Commented IP ACL Entries, Context-Based Access Control, Authentication Proxy, Turbo ACLs, Distributed Time-Based ACLs, Receive ACLs, Infrastructure Protection ACLs, Transit ACLs.

  • show access-list
  • show ip access-list
  • router(config)#access-list 101 deny icmp any any
  • router(config)#access-list 101 permit ip any any


  • router(config)#ip access-list extended test
  • router(config-ext-nacl)#permit ip host 2.2.2.2 host 3.3.3.3
  • router(config-ext-nacl)#permit tcp host 1.1.1.1 host 5.5.5.5 eq www
  • router(config-ext-nacl)#permit icmp any any
  • router(config-ext-nacl)#permit udp host 6.6.6.6 10.10.10.0 0.0.0.255 eq domain


  • ip access-group

HTTP Server

  • sh ip http server all
  • R1(config)#ip http authentication local
  • R1(config)#ip http secure-server

Configuration Guides

Activities

  1. Read wikipedia article about Cisco Internetwork Operating System
  2. Read Cisco IOS command reference: https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/fundamentals/command/Cisco_IOS_Configuration_Fundamentals_Command_Reference.pdf
  3. Read Cisco IOS Cheat Sheet: https://www.netwrix.com/cisco_commands_cheat_sheet.html
  4. Configure a user with public key access Configure public RSA key authentication
  5. Associate a user with default higher privileges using username command

See also

This article is issued from Wikiversity. The text is licensed under Creative Commons - Attribution - Sharealike. Additional terms may apply for the media files.